Login
Increased VERSION to 1.06. This will be our YAPC-NA 2007 release.
authorJeffrey Ryan Thalhammer <jeff@imaginative-software.com>
Wed, 20 Jun 2007 04:41:59 +0000 (04:41 +0000)
committerJeffrey Ryan Thalhammer <jeff@imaginative-software.com>
Wed, 20 Jun 2007 04:41:59 +0000 (04:41 +0000)
123 files changed:
Changes
INSTALL
META.yml
bin/perlcritic
lib/Perl/Critic.pm
lib/Perl/Critic/Config.pm
lib/Perl/Critic/ConfigErrors.pm
lib/Perl/Critic/Defaults.pm
lib/Perl/Critic/Document.pm
lib/Perl/Critic/Policy.pm
lib/Perl/Critic/Policy/BuiltinFunctions/ProhibitLvalueSubstr.pm
lib/Perl/Critic/Policy/BuiltinFunctions/ProhibitReverseSortBlock.pm
lib/Perl/Critic/Policy/BuiltinFunctions/ProhibitSleepViaSelect.pm
lib/Perl/Critic/Policy/BuiltinFunctions/ProhibitStringyEval.pm
lib/Perl/Critic/Policy/BuiltinFunctions/ProhibitStringySplit.pm
lib/Perl/Critic/Policy/BuiltinFunctions/ProhibitUniversalCan.pm
lib/Perl/Critic/Policy/BuiltinFunctions/ProhibitUniversalIsa.pm
lib/Perl/Critic/Policy/BuiltinFunctions/ProhibitVoidGrep.pm
lib/Perl/Critic/Policy/BuiltinFunctions/ProhibitVoidMap.pm
lib/Perl/Critic/Policy/BuiltinFunctions/RequireBlockGrep.pm
lib/Perl/Critic/Policy/BuiltinFunctions/RequireBlockMap.pm
lib/Perl/Critic/Policy/BuiltinFunctions/RequireGlobFunction.pm
lib/Perl/Critic/Policy/BuiltinFunctions/RequireSimpleSortBlock.pm
lib/Perl/Critic/Policy/ClassHierarchies/ProhibitAutoloading.pm
lib/Perl/Critic/Policy/ClassHierarchies/ProhibitExplicitISA.pm
lib/Perl/Critic/Policy/ClassHierarchies/ProhibitOneArgBless.pm
lib/Perl/Critic/Policy/CodeLayout/ProhibitHardTabs.pm
lib/Perl/Critic/Policy/CodeLayout/ProhibitParensWithBuiltins.pm
lib/Perl/Critic/Policy/CodeLayout/ProhibitQuotedWordLists.pm
lib/Perl/Critic/Policy/CodeLayout/ProhibitTrailingWhitespace.pm
lib/Perl/Critic/Policy/CodeLayout/RequireConsistentNewlines.pm
lib/Perl/Critic/Policy/CodeLayout/RequireTidyCode.pm
lib/Perl/Critic/Policy/CodeLayout/RequireTrailingCommas.pm
lib/Perl/Critic/Policy/ControlStructures/ProhibitCStyleForLoops.pm
lib/Perl/Critic/Policy/ControlStructures/ProhibitCascadingIfElse.pm
lib/Perl/Critic/Policy/ControlStructures/ProhibitDeepNests.pm
lib/Perl/Critic/Policy/ControlStructures/ProhibitMutatingListFunctions.pm
lib/Perl/Critic/Policy/ControlStructures/ProhibitPostfixControls.pm
lib/Perl/Critic/Policy/ControlStructures/ProhibitUnlessBlocks.pm
lib/Perl/Critic/Policy/ControlStructures/ProhibitUnreachableCode.pm
lib/Perl/Critic/Policy/ControlStructures/ProhibitUntilBlocks.pm
lib/Perl/Critic/Policy/Documentation/RequirePodAtEnd.pm
lib/Perl/Critic/Policy/Documentation/RequirePodSections.pm
lib/Perl/Critic/Policy/ErrorHandling/RequireCarping.pm
lib/Perl/Critic/Policy/InputOutput/ProhibitBacktickOperators.pm
lib/Perl/Critic/Policy/InputOutput/ProhibitBarewordFileHandles.pm
lib/Perl/Critic/Policy/InputOutput/ProhibitInteractiveTest.pm
lib/Perl/Critic/Policy/InputOutput/ProhibitOneArgSelect.pm
lib/Perl/Critic/Policy/InputOutput/ProhibitReadlineInForLoop.pm
lib/Perl/Critic/Policy/InputOutput/ProhibitTwoArgOpen.pm
lib/Perl/Critic/Policy/InputOutput/RequireBracedFileHandleWithPrint.pm
lib/Perl/Critic/Policy/InputOutput/RequireCheckedClose.pm
lib/Perl/Critic/Policy/InputOutput/RequireCheckedOpen.pm
lib/Perl/Critic/Policy/Miscellanea/ProhibitFormats.pm
lib/Perl/Critic/Policy/Miscellanea/ProhibitTies.pm
lib/Perl/Critic/Policy/Miscellanea/RequireRcsKeywords.pm
lib/Perl/Critic/Policy/Modules/ProhibitAutomaticExportation.pm
lib/Perl/Critic/Policy/Modules/ProhibitEvilModules.pm
lib/Perl/Critic/Policy/Modules/ProhibitExcessMainComplexity.pm
lib/Perl/Critic/Policy/Modules/ProhibitMultiplePackages.pm
lib/Perl/Critic/Policy/Modules/RequireBarewordIncludes.pm
lib/Perl/Critic/Policy/Modules/RequireEndWithOne.pm
lib/Perl/Critic/Policy/Modules/RequireExplicitPackage.pm
lib/Perl/Critic/Policy/Modules/RequireFilenameMatchesPackage.pm
lib/Perl/Critic/Policy/Modules/RequireVersionVar.pm
lib/Perl/Critic/Policy/NamingConventions/ProhibitAmbiguousNames.pm
lib/Perl/Critic/Policy/NamingConventions/ProhibitMixedCaseSubs.pm
lib/Perl/Critic/Policy/NamingConventions/ProhibitMixedCaseVars.pm
lib/Perl/Critic/Policy/References/ProhibitDoubleSigils.pm
lib/Perl/Critic/Policy/RegularExpressions/ProhibitCaptureWithoutTest.pm
lib/Perl/Critic/Policy/RegularExpressions/RequireExtendedFormatting.pm
lib/Perl/Critic/Policy/RegularExpressions/RequireLineBoundaryMatching.pm
lib/Perl/Critic/Policy/Subroutines/ProhibitAmpersandSigils.pm
lib/Perl/Critic/Policy/Subroutines/ProhibitBuiltinHomonyms.pm
lib/Perl/Critic/Policy/Subroutines/ProhibitExcessComplexity.pm
lib/Perl/Critic/Policy/Subroutines/ProhibitExplicitReturnUndef.pm
lib/Perl/Critic/Policy/Subroutines/ProhibitSubroutinePrototypes.pm
lib/Perl/Critic/Policy/Subroutines/ProtectPrivateSubs.pm
lib/Perl/Critic/Policy/Subroutines/RequireFinalReturn.pm
lib/Perl/Critic/Policy/TestingAndDebugging/ProhibitNoStrict.pm
lib/Perl/Critic/Policy/TestingAndDebugging/ProhibitNoWarnings.pm
lib/Perl/Critic/Policy/TestingAndDebugging/ProhibitProlongedStrictureOverride.pm
lib/Perl/Critic/Policy/TestingAndDebugging/RequireTestLabels.pm
lib/Perl/Critic/Policy/TestingAndDebugging/RequireUseStrict.pm
lib/Perl/Critic/Policy/TestingAndDebugging/RequireUseWarnings.pm
lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitCommaSeparatedStatements.pm
lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitConstantPragma.pm
lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitEmptyQuotes.pm
lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitEscapedCharacters.pm
lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitInterpolationOfLiterals.pm
lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitLeadingZeros.pm
lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitLongChainsOfMethodCalls.pm
lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitMismatchedOperators.pm
lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitMixedBooleanOperators.pm
lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitNoisyQuotes.pm
lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitQuotesAsQuotelikeOperatorDelimiters.pm
lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitVersionStrings.pm
lib/Perl/Critic/Policy/ValuesAndExpressions/RequireInterpolationOfMetachars.pm
lib/Perl/Critic/Policy/ValuesAndExpressions/RequireNumberSeparators.pm
lib/Perl/Critic/Policy/ValuesAndExpressions/RequireQuotedHeredocTerminator.pm
lib/Perl/Critic/Policy/ValuesAndExpressions/RequireUpperCaseHeredocTerminator.pm
lib/Perl/Critic/Policy/Variables/ProhibitConditionalDeclarations.pm
lib/Perl/Critic/Policy/Variables/ProhibitLocalVars.pm
lib/Perl/Critic/Policy/Variables/ProhibitMatchVars.pm
lib/Perl/Critic/Policy/Variables/ProhibitPackageVars.pm
lib/Perl/Critic/Policy/Variables/ProhibitPerl4PackageNames.pm
lib/Perl/Critic/Policy/Variables/ProhibitPunctuationVars.pm
lib/Perl/Critic/Policy/Variables/ProtectPrivateVars.pm
lib/Perl/Critic/Policy/Variables/RequireInitializationForLocalVars.pm
lib/Perl/Critic/Policy/Variables/RequireLexicalLoopIterators.pm
lib/Perl/Critic/Policy/Variables/RequireNegativeIndices.pm
lib/Perl/Critic/PolicyFactory.pm
lib/Perl/Critic/PolicyListing.pm
lib/Perl/Critic/ProfilePrototype.pm
lib/Perl/Critic/Statistics.pm
lib/Perl/Critic/TestUtils.pm
lib/Perl/Critic/Theme.pm
lib/Perl/Critic/UserProfile.pm
lib/Perl/Critic/Utils.pm
lib/Perl/Critic/Utils/McCabe.pm
lib/Perl/Critic/Utils/PPI.pm
lib/Perl/Critic/Violation.pm
t/00_modules.t

diff --git a/Changes b/Changes
index 1fdaae6..aab6cb3 100644 (file)
--- a/Changes
+++ b/Changes
@@ -5,7 +5,7 @@
 # $Revision$
 ##############################################################################
 
-[1.xxx]  Released on 2007-06-xx
+[1.06]  Released on 2007-06-xx
 
      New Features:
      * perlcritic now emits errors for all the problems it can find for the
diff --git a/INSTALL b/INSTALL
index 552e7db..727ae3e 100644 (file)
--- a/INSTALL
+++ b/INSTALL
@@ -18,8 +18,8 @@ INSTALLATION
      To install Perl::Critic with C<make> give the following 
      commands to your favorite shell:
 
-         tar -zxf Perl-Critic-1.053.tar.gz
-         cd Perl-Critic-1.053
+         tar -zxf Perl-Critic-1.06.tar.gz
+         cd Perl-Critic-1.06
          perl Makefile.PL
          make
          make test
@@ -27,8 +27,8 @@ INSTALLATION
 
      Or if you prefer C<Module::Build>, try this:
 
-         tar -zxf Perl-Critic-1.053.tar.gz
-         cd Perl-Critic-1.053
+         tar -zxf Perl-Critic-1.06.tar.gz
+         cd Perl-Critic-1.06
          perl Build.pl
          ./Build
          ./Build test
index 67bd1bb..04f7557 100644 (file)
--- a/META.yml
+++ b/META.yml
@@ -1,6 +1,6 @@
 ---
 name: Perl-Critic
-version: 1.053
+version: 1.06
 author:
   - 'Jeffrey Thalhammer <thaljef@cpan.org>'
 abstract: Critique Perl source code for best-practices
@@ -29,343 +29,358 @@ recommends:
 provides:
   Perl::Critic:
     file: lib/Perl/Critic.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Config:
     file: lib/Perl/Critic/Config.pm
-    version: 1.053
+    version: 1.06
+  Perl::Critic::ConfigErrors:
+    file: lib/Perl/Critic/ConfigErrors.pm
+    version: 1.06
   Perl::Critic::Defaults:
     file: lib/Perl/Critic/Defaults.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Document:
     file: lib/Perl/Critic/Document.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy:
     file: lib/Perl/Critic/Policy.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::BuiltinFunctions::ProhibitLvalueSubstr:
     file: lib/Perl/Critic/Policy/BuiltinFunctions/ProhibitLvalueSubstr.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::BuiltinFunctions::ProhibitReverseSortBlock:
     file: lib/Perl/Critic/Policy/BuiltinFunctions/ProhibitReverseSortBlock.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::BuiltinFunctions::ProhibitSleepViaSelect:
     file: lib/Perl/Critic/Policy/BuiltinFunctions/ProhibitSleepViaSelect.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::BuiltinFunctions::ProhibitStringyEval:
     file: lib/Perl/Critic/Policy/BuiltinFunctions/ProhibitStringyEval.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::BuiltinFunctions::ProhibitStringySplit:
     file: lib/Perl/Critic/Policy/BuiltinFunctions/ProhibitStringySplit.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::BuiltinFunctions::ProhibitUniversalCan:
     file: lib/Perl/Critic/Policy/BuiltinFunctions/ProhibitUniversalCan.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::BuiltinFunctions::ProhibitUniversalIsa:
     file: lib/Perl/Critic/Policy/BuiltinFunctions/ProhibitUniversalIsa.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::BuiltinFunctions::ProhibitVoidGrep:
     file: lib/Perl/Critic/Policy/BuiltinFunctions/ProhibitVoidGrep.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::BuiltinFunctions::ProhibitVoidMap:
     file: lib/Perl/Critic/Policy/BuiltinFunctions/ProhibitVoidMap.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::BuiltinFunctions::RequireBlockGrep:
     file: lib/Perl/Critic/Policy/BuiltinFunctions/RequireBlockGrep.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::BuiltinFunctions::RequireBlockMap:
     file: lib/Perl/Critic/Policy/BuiltinFunctions/RequireBlockMap.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::BuiltinFunctions::RequireGlobFunction:
     file: lib/Perl/Critic/Policy/BuiltinFunctions/RequireGlobFunction.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::BuiltinFunctions::RequireSimpleSortBlock:
     file: lib/Perl/Critic/Policy/BuiltinFunctions/RequireSimpleSortBlock.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::ClassHierarchies::ProhibitAutoloading:
     file: lib/Perl/Critic/Policy/ClassHierarchies/ProhibitAutoloading.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::ClassHierarchies::ProhibitExplicitISA:
     file: lib/Perl/Critic/Policy/ClassHierarchies/ProhibitExplicitISA.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::ClassHierarchies::ProhibitOneArgBless:
     file: lib/Perl/Critic/Policy/ClassHierarchies/ProhibitOneArgBless.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::CodeLayout::ProhibitHardTabs:
     file: lib/Perl/Critic/Policy/CodeLayout/ProhibitHardTabs.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::CodeLayout::ProhibitParensWithBuiltins:
     file: lib/Perl/Critic/Policy/CodeLayout/ProhibitParensWithBuiltins.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::CodeLayout::ProhibitQuotedWordLists:
     file: lib/Perl/Critic/Policy/CodeLayout/ProhibitQuotedWordLists.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::CodeLayout::ProhibitTrailingWhitespace:
     file: lib/Perl/Critic/Policy/CodeLayout/ProhibitTrailingWhitespace.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::CodeLayout::RequireConsistentNewlines:
     file: lib/Perl/Critic/Policy/CodeLayout/RequireConsistentNewlines.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::CodeLayout::RequireTidyCode:
     file: lib/Perl/Critic/Policy/CodeLayout/RequireTidyCode.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::CodeLayout::RequireTrailingCommas:
     file: lib/Perl/Critic/Policy/CodeLayout/RequireTrailingCommas.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::ControlStructures::ProhibitCStyleForLoops:
     file: lib/Perl/Critic/Policy/ControlStructures/ProhibitCStyleForLoops.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::ControlStructures::ProhibitCascadingIfElse:
     file: lib/Perl/Critic/Policy/ControlStructures/ProhibitCascadingIfElse.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::ControlStructures::ProhibitDeepNests:
     file: lib/Perl/Critic/Policy/ControlStructures/ProhibitDeepNests.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::ControlStructures::ProhibitMutatingListFunctions:
     file: lib/Perl/Critic/Policy/ControlStructures/ProhibitMutatingListFunctions.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::ControlStructures::ProhibitPostfixControls:
     file: lib/Perl/Critic/Policy/ControlStructures/ProhibitPostfixControls.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::ControlStructures::ProhibitUnlessBlocks:
     file: lib/Perl/Critic/Policy/ControlStructures/ProhibitUnlessBlocks.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::ControlStructures::ProhibitUnreachableCode:
     file: lib/Perl/Critic/Policy/ControlStructures/ProhibitUnreachableCode.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::ControlStructures::ProhibitUntilBlocks:
     file: lib/Perl/Critic/Policy/ControlStructures/ProhibitUntilBlocks.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::Documentation::RequirePodAtEnd:
     file: lib/Perl/Critic/Policy/Documentation/RequirePodAtEnd.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::Documentation::RequirePodSections:
     file: lib/Perl/Critic/Policy/Documentation/RequirePodSections.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::ErrorHandling::RequireCarping:
     file: lib/Perl/Critic/Policy/ErrorHandling/RequireCarping.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::InputOutput::ProhibitBacktickOperators:
     file: lib/Perl/Critic/Policy/InputOutput/ProhibitBacktickOperators.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::InputOutput::ProhibitBarewordFileHandles:
     file: lib/Perl/Critic/Policy/InputOutput/ProhibitBarewordFileHandles.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::InputOutput::ProhibitInteractiveTest:
     file: lib/Perl/Critic/Policy/InputOutput/ProhibitInteractiveTest.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::InputOutput::ProhibitOneArgSelect:
     file: lib/Perl/Critic/Policy/InputOutput/ProhibitOneArgSelect.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::InputOutput::ProhibitReadlineInForLoop:
     file: lib/Perl/Critic/Policy/InputOutput/ProhibitReadlineInForLoop.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::InputOutput::ProhibitTwoArgOpen:
     file: lib/Perl/Critic/Policy/InputOutput/ProhibitTwoArgOpen.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::InputOutput::RequireBracedFileHandleWithPrint:
     file: lib/Perl/Critic/Policy/InputOutput/RequireBracedFileHandleWithPrint.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::InputOutput::RequireCheckedClose:
     file: lib/Perl/Critic/Policy/InputOutput/RequireCheckedClose.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::InputOutput::RequireCheckedOpen:
     file: lib/Perl/Critic/Policy/InputOutput/RequireCheckedOpen.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::Miscellanea::ProhibitFormats:
     file: lib/Perl/Critic/Policy/Miscellanea/ProhibitFormats.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::Miscellanea::ProhibitTies:
     file: lib/Perl/Critic/Policy/Miscellanea/ProhibitTies.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::Miscellanea::RequireRcsKeywords:
     file: lib/Perl/Critic/Policy/Miscellanea/RequireRcsKeywords.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::Modules::ProhibitAutomaticExportation:
     file: lib/Perl/Critic/Policy/Modules/ProhibitAutomaticExportation.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::Modules::ProhibitEvilModules:
     file: lib/Perl/Critic/Policy/Modules/ProhibitEvilModules.pm
-    version: 1.053
+    version: 1.06
+  Perl::Critic::Policy::Modules::ProhibitExcessMainComplexity:
+    file: lib/Perl/Critic/Policy/Modules/ProhibitExcessMainComplexity.pm
+    version: 1.06
   Perl::Critic::Policy::Modules::ProhibitMultiplePackages:
     file: lib/Perl/Critic/Policy/Modules/ProhibitMultiplePackages.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::Modules::RequireBarewordIncludes:
     file: lib/Perl/Critic/Policy/Modules/RequireBarewordIncludes.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::Modules::RequireEndWithOne:
     file: lib/Perl/Critic/Policy/Modules/RequireEndWithOne.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::Modules::RequireExplicitPackage:
     file: lib/Perl/Critic/Policy/Modules/RequireExplicitPackage.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::Modules::RequireFilenameMatchesPackage:
     file: lib/Perl/Critic/Policy/Modules/RequireFilenameMatchesPackage.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::Modules::RequireVersionVar:
     file: lib/Perl/Critic/Policy/Modules/RequireVersionVar.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::NamingConventions::ProhibitAmbiguousNames:
     file: lib/Perl/Critic/Policy/NamingConventions/ProhibitAmbiguousNames.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::NamingConventions::ProhibitMixedCaseSubs:
     file: lib/Perl/Critic/Policy/NamingConventions/ProhibitMixedCaseSubs.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::NamingConventions::ProhibitMixedCaseVars:
     file: lib/Perl/Critic/Policy/NamingConventions/ProhibitMixedCaseVars.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::References::ProhibitDoubleSigils:
     file: lib/Perl/Critic/Policy/References/ProhibitDoubleSigils.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::RegularExpressions::ProhibitCaptureWithoutTest:
     file: lib/Perl/Critic/Policy/RegularExpressions/ProhibitCaptureWithoutTest.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::RegularExpressions::RequireExtendedFormatting:
     file: lib/Perl/Critic/Policy/RegularExpressions/RequireExtendedFormatting.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::RegularExpressions::RequireLineBoundaryMatching:
     file: lib/Perl/Critic/Policy/RegularExpressions/RequireLineBoundaryMatching.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::Subroutines::ProhibitAmpersandSigils:
     file: lib/Perl/Critic/Policy/Subroutines/ProhibitAmpersandSigils.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::Subroutines::ProhibitBuiltinHomonyms:
     file: lib/Perl/Critic/Policy/Subroutines/ProhibitBuiltinHomonyms.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::Subroutines::ProhibitExcessComplexity:
     file: lib/Perl/Critic/Policy/Subroutines/ProhibitExcessComplexity.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::Subroutines::ProhibitExplicitReturnUndef:
     file: lib/Perl/Critic/Policy/Subroutines/ProhibitExplicitReturnUndef.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::Subroutines::ProhibitSubroutinePrototypes:
     file: lib/Perl/Critic/Policy/Subroutines/ProhibitSubroutinePrototypes.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::Subroutines::ProtectPrivateSubs:
     file: lib/Perl/Critic/Policy/Subroutines/ProtectPrivateSubs.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::Subroutines::RequireFinalReturn:
     file: lib/Perl/Critic/Policy/Subroutines/RequireFinalReturn.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::TestingAndDebugging::ProhibitNoStrict:
     file: lib/Perl/Critic/Policy/TestingAndDebugging/ProhibitNoStrict.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::TestingAndDebugging::ProhibitNoWarnings:
     file: lib/Perl/Critic/Policy/TestingAndDebugging/ProhibitNoWarnings.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::TestingAndDebugging::ProhibitProlongedStrictureOverride:
     file: lib/Perl/Critic/Policy/TestingAndDebugging/ProhibitProlongedStrictureOverride.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::TestingAndDebugging::RequireTestLabels:
     file: lib/Perl/Critic/Policy/TestingAndDebugging/RequireTestLabels.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::TestingAndDebugging::RequireUseStrict:
     file: lib/Perl/Critic/Policy/TestingAndDebugging/RequireUseStrict.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::TestingAndDebugging::RequireUseWarnings:
     file: lib/Perl/Critic/Policy/TestingAndDebugging/RequireUseWarnings.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::ValuesAndExpressions::ProhibitCommaSeparatedStatements:
     file: lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitCommaSeparatedStatements.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::ValuesAndExpressions::ProhibitConstantPragma:
     file: lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitConstantPragma.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::ValuesAndExpressions::ProhibitEmptyQuotes:
     file: lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitEmptyQuotes.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::ValuesAndExpressions::ProhibitEscapedCharacters:
     file: lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitEscapedCharacters.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::ValuesAndExpressions::ProhibitInterpolationOfLiterals:
     file: lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitInterpolationOfLiterals.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::ValuesAndExpressions::ProhibitLeadingZeros:
     file: lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitLeadingZeros.pm
-    version: 1.053
+    version: 1.06
+  Perl::Critic::Policy::ValuesAndExpressions::ProhibitLongChainsOfMethodCalls:
+    file: lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitLongChainsOfMethodCalls.pm
+    version: 1.06
   Perl::Critic::Policy::ValuesAndExpressions::ProhibitMismatchedOperators:
     file: lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitMismatchedOperators.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::ValuesAndExpressions::ProhibitMixedBooleanOperators:
     file: lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitMixedBooleanOperators.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::ValuesAndExpressions::ProhibitNoisyQuotes:
     file: lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitNoisyQuotes.pm
-    version: 1.053
+    version: 1.06
+  Perl::Critic::Policy::ValuesAndExpressions::ProhibitQuotesAsQuotelikeOperatorDelimiters:
+    file: lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitQuotesAsQuotelikeOperatorDelimiters.pm
+    version: 1.06
   Perl::Critic::Policy::ValuesAndExpressions::ProhibitVersionStrings:
     file: lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitVersionStrings.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::ValuesAndExpressions::RequireInterpolationOfMetachars:
     file: lib/Perl/Critic/Policy/ValuesAndExpressions/RequireInterpolationOfMetachars.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::ValuesAndExpressions::RequireNumberSeparators:
     file: lib/Perl/Critic/Policy/ValuesAndExpressions/RequireNumberSeparators.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::ValuesAndExpressions::RequireQuotedHeredocTerminator:
     file: lib/Perl/Critic/Policy/ValuesAndExpressions/RequireQuotedHeredocTerminator.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::ValuesAndExpressions::RequireUpperCaseHeredocTerminator:
     file: lib/Perl/Critic/Policy/ValuesAndExpressions/RequireUpperCaseHeredocTerminator.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::Variables::ProhibitConditionalDeclarations:
     file: lib/Perl/Critic/Policy/Variables/ProhibitConditionalDeclarations.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::Variables::ProhibitLocalVars:
     file: lib/Perl/Critic/Policy/Variables/ProhibitLocalVars.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::Variables::ProhibitMatchVars:
     file: lib/Perl/Critic/Policy/Variables/ProhibitMatchVars.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::Variables::ProhibitPackageVars:
     file: lib/Perl/Critic/Policy/Variables/ProhibitPackageVars.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::Variables::ProhibitPerl4PackageNames:
     file: lib/Perl/Critic/Policy/Variables/ProhibitPerl4PackageNames.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::Variables::ProhibitPunctuationVars:
     file: lib/Perl/Critic/Policy/Variables/ProhibitPunctuationVars.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::Variables::ProtectPrivateVars:
     file: lib/Perl/Critic/Policy/Variables/ProtectPrivateVars.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::Variables::RequireInitializationForLocalVars:
     file: lib/Perl/Critic/Policy/Variables/RequireInitializationForLocalVars.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::Variables::RequireLexicalLoopIterators:
     file: lib/Perl/Critic/Policy/Variables/RequireLexicalLoopIterators.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Policy::Variables::RequireNegativeIndices:
     file: lib/Perl/Critic/Policy/Variables/RequireNegativeIndices.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::PolicyFactory:
     file: lib/Perl/Critic/PolicyFactory.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::PolicyListing:
     file: lib/Perl/Critic/PolicyListing.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::ProfilePrototype:
     file: lib/Perl/Critic/ProfilePrototype.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Statistics:
     file: lib/Perl/Critic/Statistics.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::TestUtils:
     file: lib/Perl/Critic/TestUtils.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Theme:
     file: lib/Perl/Critic/Theme.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::UserProfile:
     file: lib/Perl/Critic/UserProfile.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Utils:
     file: lib/Perl/Critic/Utils.pm
-    version: 1.053
+    version: 1.06
   Perl::Critic::Utils::McCabe:
     file: lib/Perl/Critic/Utils/McCabe.pm
-    version: 1.053
+    version: 1.06
+  Perl::Critic::Utils::PPI:
+    file: lib/Perl/Critic/Utils/PPI.pm
+    version: 1.06
   Perl::Critic::Violation:
     file: lib/Perl/Critic/Violation.pm
-    version: 1.053
+    version: 1.06
 generated_by: Module::Build version 0.2808
 meta-spec:
   url: http://module-build.sourceforge.net/META-spec-v1.2.html
index 537aec4..b085124 100755 (executable)
@@ -22,7 +22,7 @@ use Pod::Usage qw(pod2usage);
 
 #-----------------------------------------------------------------------------
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 # Begin script.  Don't run when loaded as a library
index 8fee26c..9e7a034 100644 (file)
@@ -25,7 +25,7 @@ use PPI::Document::File;
 
 #-----------------------------------------------------------------------------
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 our @EXPORT_OK = qw(&critique);
 
 #-----------------------------------------------------------------------------
index 1a5948d..a89d5ac 100644 (file)
@@ -25,7 +25,7 @@ use Perl::Critic::Utils qw{
 
 #-----------------------------------------------------------------------------
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 # Constructor
index d8fd771..daea644 100644 (file)
@@ -17,7 +17,7 @@ use overload ( q{""} => 'to_string' );
 
 #-----------------------------------------------------------------------------
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 # Constructor
index bfd46ea..8bc140d 100644 (file)
@@ -15,7 +15,7 @@ use Perl::Critic::Utils qw{
     :booleans :characters :severities :data_conversion $DEFAULT_VERBOSITY
 };
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 22bcc78..75521c4 100644 (file)
@@ -14,7 +14,7 @@ use Scalar::Util qw(weaken);
 
 #-----------------------------------------------------------------------------
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 7f0d5a8..61bb761 100644 (file)
@@ -21,7 +21,7 @@ use Perl::Critic::Violation qw();
 use String::Format qw(stringf);
 use overload ( q{""} => 'to_string', cmp => '_compare' );
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index f45afbc..4316686 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index daa9594..bcc75f5 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index d8981ef..1c4f032 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification :ppi };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 9735db1..9ea9158 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification :ppi };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index ad85040..f6e042f 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :characters :severities :classification :ppi };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index a1cb6c7..60bcb86 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index bb2f0d3..94cedc0 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 65b1fb5..726c16b 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification &is_in_void_context };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 2148ea1..1963f93 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification &is_in_void_context };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index f569e9b..738fd10 100644 (file)
@@ -16,7 +16,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification :ppi };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index a44f09c..f698cb7 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification :ppi };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 3904097..0636ab3 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index a97cb4c..6e5886c 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 8329f76..f7cd7e4 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 8112fe3..8c0316a 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index e287330..2bf6264 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification :ppi };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 98090a7..002fd8a 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :booleans :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index ad7aa01..44557a5 100644 (file)
@@ -14,7 +14,7 @@ use Perl::Critic::Utils qw{
 };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index f026945..cb637ab 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :characters :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 37a4597..51bc6ce 100644 (file)
@@ -19,7 +19,7 @@ use Perl::Critic::Utils qw{ :characters :severities };
 
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 4e8dd5c..9b417b3 100644 (file)
@@ -14,7 +14,7 @@ use PPI::Token::Whitespace;
 use English qw(-no_match_vars);
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 my $LINE_END = qr/\015{1,2}\012|\012|\015/mxs;
 
index e9097b9..2cfa2a6 100644 (file)
@@ -13,7 +13,7 @@ use English qw(-no_match_vars);
 use Perl::Critic::Utils qw{ :characters :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index f1e2dda..46cb4db 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :characters :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index e30092a..17d696d 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :characters :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 7afe368..ea90a81 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 3c31fbc..9549ccb 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 56d395a..bdd991e 100644 (file)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils qw{ :severities :data_conversion :classification :ppi };
 use List::MoreUtils qw( none any );
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 3ad5d23..fc7a044 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :data_conversion :classification };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index c2412fd..599da5e 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index fb4a102..0139db7 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :data_conversion :classification };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 my @terminals = qw( die exit croak confess );
 my %terminals = hashify( @terminals );
index b049f10..fff9721 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index cc225e2..2153152 100644 (file)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils qw{ :severities };
 use List::Util qw(first);
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index cc82ff6..9286546 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index c4b631d..0b6d2fb 100644 (file)
@@ -15,7 +15,7 @@ use Perl::Critic::Utils qw{
 use Perl::Critic::Utils::PPI qw{ &is_ppi_expression_or_generic_statement };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index e13a42d..410893c 100644 (file)
@@ -14,7 +14,7 @@ use Perl::Critic::Utils qw{ :severities &is_in_void_context };
 
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index cd5ca82..3bcac64 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification :ppi };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index e3e6de6..db2b41a 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 3593871..818cc31 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification :ppi };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 8c771ae..a0069dd 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 01328d5..a055b0b 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification :ppi };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 7c4f568..947fb8c 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification :data_conversion };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index f99d674..e266fb4 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index d05d9ad..5680a4f 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 4446d4d..2259a59 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index f81f87e..25d5be7 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 122c7cd..a7bc5b4 100644 (file)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils qw{ :severities :data_conversion };
 use List::MoreUtils qw(none);
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index b23bf71..f502a4f 100644 (file)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils qw{ :severities };
 use List::MoreUtils qw(any);
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 37caba9..c665182 100644 (file)
@@ -13,7 +13,7 @@ use List::MoreUtils qw(any);
 use Perl::Critic::Utils qw{ :severities :data_conversion };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 0cba57e..0c5643f 100644 (file)
@@ -17,7 +17,7 @@ use base 'Perl::Critic::Policy';
 
 #-----------------------------------------------------------------------------
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index ce05e7b..ecdff23 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 823044a..54adf62 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 3ee3152..b95899f 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 2d560f8..0058f94 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 86a14ea..411e5c4 100644 (file)
@@ -13,7 +13,7 @@ use File::Spec;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 3b41983..f80db93 100644 (file)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils qw{ :severities };
 use List::MoreUtils qw(any);
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
@@ -121,8 +121,8 @@ This Policy scans your file for any package variable named
 C<$VERSION>.  I'm assuming that you are using C<strict>, so you'll
 have to declare it like one of these:
 
-  our $VERSION = 1.0531;
-  $MyPackage::VERSION = 1.0531;
+  our $VERSION = 1.061;
+  $MyPackage::VERSION = 1.061;
   use vars qw($VERSION);
 
 A common practice is to use the C<$Revision$> keyword to automatically
index b0164f3..29d22c0 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :data_conversion };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index dccfa11..fc5a5b5 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index ccc1159..6ca9727 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index d784ef3..d315a1b 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 7ae0a7b..a062ee2 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index d36b646..074b710 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 3aca3dc..559a960 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 2cff4a3..359cd94 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 0c2db91..762f0dc 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :data_conversion :classification };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index f794b6c..11065e4 100644 (file)
@@ -15,7 +15,7 @@ use Perl::Critic::Utils::McCabe qw{ &calculate_mccabe_of_sub };
 
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 6c92eef..bb6682d 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index a427836..441fac1 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 7805836..46f8cc1 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 46df4f9..879940f 100644 (file)
@@ -13,7 +13,7 @@ use Carp qw(confess);
 use Perl::Critic::Utils qw{ :severities :data_conversion };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 0fb9892..a85e261 100644 (file)
@@ -13,7 +13,7 @@ use List::MoreUtils qw(all);
 use Perl::Critic::Utils qw{ :severities :data_conversion };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index af1deeb..3e254a3 100644 (file)
@@ -13,7 +13,7 @@ use List::MoreUtils qw(all);
 use Perl::Critic::Utils qw{ :severities :data_conversion };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index c5ee216..b724d0a 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index dea012f..a98de74 100644 (file)
@@ -15,7 +15,7 @@ use Perl::Critic::Utils qw{
 };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 my %label_arg_pos = (
    ok        => 1,
index 136eda9..f394085 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 49d8866..5078cd5 100644 (file)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils qw{ :severities };
 use List::Util qw(first);
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 654d897..b3ac31f 100644 (file)
@@ -15,7 +15,7 @@ use Perl::Critic::Utils::PPI qw{ &is_ppi_statement_subclass };
 
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 3c42256..5c746d3 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 94dd1fe..92201a9 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 6e7ddcd..5aec86e 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 662863c..51b40ba 100644 (file)
@@ -13,7 +13,7 @@ use List::MoreUtils qw(any);
 use Perl::Critic::Utils qw{ :severities :data_conversion };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 678ae4b..6e19826 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index c581982..82d671f 100644 (file)
@@ -14,7 +14,7 @@ use Perl::Critic::Utils qw{ :characters :severities };
 use Perl::Critic::Utils::PPI qw{ &is_ppi_expression_or_generic_statement };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index b67a796..3f85d48 100644 (file)
@@ -11,7 +11,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 673bc2c..dc3d863 100644 (file)
@@ -15,7 +15,7 @@ use base 'Perl::Critic::Policy';
 
 #-----------------------------------------------------------------------------
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 992737c..291fe30 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index f231907..72a8c24 100644 (file)
@@ -14,7 +14,7 @@ use Perl::Critic::Utils qw{ :characters :severities :data_conversion };
 
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 5d7418a..5873b3f 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 1cd6e2c..2f7dd25 100644 (file)
@@ -14,7 +14,7 @@ use base 'Perl::Critic::Policy';
 
 #-----------------------------------------------------------------------------
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 6d08c13..afda713 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 51117de..51185ac 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index ad6db9a..3f9fc8a 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 47d94d9..87753c1 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification :data_conversion };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 961b4f5..18f4124 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 8be2ce6..ec556d7 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :data_conversion };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 00b952d..244adb8 100644 (file)
@@ -14,7 +14,7 @@ use List::MoreUtils qw(all any);
 use Carp qw( carp );
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 3937712..3cb28a3 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :characters :severities :classification };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index a5c93eb..c782903 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :data_conversion };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 5b014db..d413435 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index cf3fe0b..f353111 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 20941c8..d217cbc 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index e5a9ba3..b81f4c5 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index c54d73a..d858d05 100644 (file)
@@ -22,7 +22,7 @@ use Perl::Critic::Utils qw{
 };
 use Perl::Critic::ConfigErrors;
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index c11ca37..28d1801 100644 (file)
@@ -15,7 +15,7 @@ use English qw(-no_match_vars);
 use Perl::Critic::Policy qw();
 use overload ( q{""} => 'to_string');
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 8956bed..463e804 100644 (file)
@@ -15,7 +15,7 @@ use English qw(-no_match_vars);
 use Perl::Critic::Policy qw();
 use overload ( q{""} => 'to_string' );
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 1cc1e01..697066c 100644 (file)
@@ -16,7 +16,7 @@ use Perl::Critic::Utils::McCabe qw{ &calculate_mccabe_of_sub };
 
 #-----------------------------------------------------------------------------
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index bfece87..b4d8db1 100644 (file)
@@ -21,7 +21,7 @@ use Perl::Critic;
 use Perl::Critic::Utils qw{ :data_conversion };
 use Perl::Critic::PolicyFactory (-test => 1);
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 our @EXPORT_OK = qw(
     pcritique pcritique_with_violations
     critique  critique_with_violations
index dc2a45f..f58cb1d 100644 (file)
@@ -19,7 +19,7 @@ use Perl::Critic::Utils qw{ :characters :data_conversion };
 
 #-----------------------------------------------------------------------------
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index 562097e..8d121de 100644 (file)
@@ -16,7 +16,7 @@ use File::Spec qw();
 use Perl::Critic::Defaults qw();
 use Perl::Critic::Utils qw{ :characters &policy_long_name &policy_short_name };
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index fadfaf1..2620354 100644 (file)
@@ -17,7 +17,7 @@ use B::Keywords qw();
 
 use base 'Exporter';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 # Exportable symbols here.
index 2df2370..ea0457b 100644 (file)
@@ -16,7 +16,7 @@ use base 'Exporter';
 
 #-----------------------------------------------------------------------------
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index fc46006..4ec8226 100644 (file)
@@ -14,7 +14,7 @@ use Perl::Critic::Utils qw{ :data_conversion :classification };
 
 use base 'Exporter';
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #-----------------------------------------------------------------------------
 
index ed9cb85..6e352e6 100644 (file)
@@ -18,7 +18,7 @@ use Perl::Critic::Utils qw{ :characters :internal_lookup };
 use String::Format qw(stringf);
 use overload ( q{""} => 'to_string', cmp => '_compare' );
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 #Class variables...
 our $FORMAT = "%m at line %l, column %c. %e.\n"; #Default stringy format
index 7df6bc5..c9725ca 100644 (file)
@@ -14,7 +14,7 @@ use Test::More;
 use Perl::Critic::TestUtils qw(bundled_policy_names);
 use English qw(-no_match_vars);
 
-our $VERSION = 1.053;
+our $VERSION = 1.06;
 
 my @bundled_policy_names = bundled_policy_names();
 plan tests => 106 + 14 * scalar @bundled_policy_names;