Login
RT #67760: RequireLexicalLoopIterators vs perl version
authorTom Wyant <harryfmudd@comcast.net>
Thu, 28 Apr 2011 00:45:39 +0000 (00:45 +0000)
committerTom Wyant <harryfmudd@comcast.net>
Thu, 28 Apr 2011 00:45:39 +0000 (00:45 +0000)
Tweak docs and test, since the requester points out that 'use 5.003;'
does not parse.

This is on top of SVN revision 4074.

lib/Perl/Critic/Policy/Variables/RequireLexicalLoopIterators.pm
t/Variables/RequireLexicalLoopIterators.run

index 5e34367..1ec9470 100644 (file)
@@ -136,7 +136,7 @@ one it was.
 
 Lexical loop variables were introduced in Perl 5.004. This policy does
 not report violations on code which explicitly specifies an earlier
-version of Perl (e.g. C<use 5.002;>).
+version of Perl (e.g. C<require 5.002;>).
 
 
 =head1 CONFIGURATION
index 347ccf9..ae599f5 100644 (file)
@@ -60,7 +60,7 @@ until ( $condition ) {}
 ## failures 0
 ## cut
 
-use 5.003;
+require 5.003;
 
 foreach $foo ( @list ) {
     bar( $foo );