Login
Increased VERSION to 1.05 v1.05
authorJeffrey Ryan Thalhammer <jeff@imaginative-software.com>
Tue, 20 Mar 2007 06:56:18 +0000 (06:56 +0000)
committerJeffrey Ryan Thalhammer <jeff@imaginative-software.com>
Tue, 20 Mar 2007 06:56:18 +0000 (06:56 +0000)
116 files changed:
Changes
INSTALL
META.yml
bin/perlcritic
lib/Perl/Critic.pm
lib/Perl/Critic/Config.pm
lib/Perl/Critic/Defaults.pm
lib/Perl/Critic/Document.pm
lib/Perl/Critic/Policy.pm
lib/Perl/Critic/Policy/BuiltinFunctions/ProhibitLvalueSubstr.pm
lib/Perl/Critic/Policy/BuiltinFunctions/ProhibitReverseSortBlock.pm
lib/Perl/Critic/Policy/BuiltinFunctions/ProhibitSleepViaSelect.pm
lib/Perl/Critic/Policy/BuiltinFunctions/ProhibitStringyEval.pm
lib/Perl/Critic/Policy/BuiltinFunctions/ProhibitStringySplit.pm
lib/Perl/Critic/Policy/BuiltinFunctions/ProhibitUniversalCan.pm
lib/Perl/Critic/Policy/BuiltinFunctions/ProhibitUniversalIsa.pm
lib/Perl/Critic/Policy/BuiltinFunctions/ProhibitVoidGrep.pm
lib/Perl/Critic/Policy/BuiltinFunctions/ProhibitVoidMap.pm
lib/Perl/Critic/Policy/BuiltinFunctions/RequireBlockGrep.pm
lib/Perl/Critic/Policy/BuiltinFunctions/RequireBlockMap.pm
lib/Perl/Critic/Policy/BuiltinFunctions/RequireGlobFunction.pm
lib/Perl/Critic/Policy/BuiltinFunctions/RequireSimpleSortBlock.pm
lib/Perl/Critic/Policy/ClassHierarchies/ProhibitAutoloading.pm
lib/Perl/Critic/Policy/ClassHierarchies/ProhibitExplicitISA.pm
lib/Perl/Critic/Policy/ClassHierarchies/ProhibitOneArgBless.pm
lib/Perl/Critic/Policy/CodeLayout/ProhibitHardTabs.pm
lib/Perl/Critic/Policy/CodeLayout/ProhibitParensWithBuiltins.pm
lib/Perl/Critic/Policy/CodeLayout/ProhibitQuotedWordLists.pm
lib/Perl/Critic/Policy/CodeLayout/ProhibitTrailingWhitespace.pm
lib/Perl/Critic/Policy/CodeLayout/RequireConsistentNewlines.pm
lib/Perl/Critic/Policy/CodeLayout/RequireTidyCode.pm
lib/Perl/Critic/Policy/CodeLayout/RequireTrailingCommas.pm
lib/Perl/Critic/Policy/ControlStructures/ProhibitCStyleForLoops.pm
lib/Perl/Critic/Policy/ControlStructures/ProhibitCascadingIfElse.pm
lib/Perl/Critic/Policy/ControlStructures/ProhibitDeepNests.pm
lib/Perl/Critic/Policy/ControlStructures/ProhibitMutatingListFunctions.pm
lib/Perl/Critic/Policy/ControlStructures/ProhibitPostfixControls.pm
lib/Perl/Critic/Policy/ControlStructures/ProhibitUnlessBlocks.pm
lib/Perl/Critic/Policy/ControlStructures/ProhibitUnreachableCode.pm
lib/Perl/Critic/Policy/ControlStructures/ProhibitUntilBlocks.pm
lib/Perl/Critic/Policy/Documentation/RequirePodAtEnd.pm
lib/Perl/Critic/Policy/Documentation/RequirePodSections.pm
lib/Perl/Critic/Policy/ErrorHandling/RequireCarping.pm
lib/Perl/Critic/Policy/InputOutput/ProhibitBacktickOperators.pm
lib/Perl/Critic/Policy/InputOutput/ProhibitBarewordFileHandles.pm
lib/Perl/Critic/Policy/InputOutput/ProhibitInteractiveTest.pm
lib/Perl/Critic/Policy/InputOutput/ProhibitOneArgSelect.pm
lib/Perl/Critic/Policy/InputOutput/ProhibitReadlineInForLoop.pm
lib/Perl/Critic/Policy/InputOutput/ProhibitTwoArgOpen.pm
lib/Perl/Critic/Policy/InputOutput/RequireBracedFileHandleWithPrint.pm
lib/Perl/Critic/Policy/InputOutput/RequireCheckedClose.pm
lib/Perl/Critic/Policy/InputOutput/RequireCheckedOpen.pm
lib/Perl/Critic/Policy/Miscellanea/ProhibitFormats.pm
lib/Perl/Critic/Policy/Miscellanea/ProhibitTies.pm
lib/Perl/Critic/Policy/Miscellanea/RequireRcsKeywords.pm
lib/Perl/Critic/Policy/Modules/ProhibitAutomaticExportation.pm
lib/Perl/Critic/Policy/Modules/ProhibitEvilModules.pm
lib/Perl/Critic/Policy/Modules/ProhibitMultiplePackages.pm
lib/Perl/Critic/Policy/Modules/RequireBarewordIncludes.pm
lib/Perl/Critic/Policy/Modules/RequireEndWithOne.pm
lib/Perl/Critic/Policy/Modules/RequireExplicitPackage.pm
lib/Perl/Critic/Policy/Modules/RequireFilenameMatchesPackage.pm
lib/Perl/Critic/Policy/Modules/RequireVersionVar.pm
lib/Perl/Critic/Policy/NamingConventions/ProhibitAmbiguousNames.pm
lib/Perl/Critic/Policy/NamingConventions/ProhibitMixedCaseSubs.pm
lib/Perl/Critic/Policy/NamingConventions/ProhibitMixedCaseVars.pm
lib/Perl/Critic/Policy/References/ProhibitDoubleSigils.pm
lib/Perl/Critic/Policy/RegularExpressions/ProhibitCaptureWithoutTest.pm
lib/Perl/Critic/Policy/RegularExpressions/RequireExtendedFormatting.pm
lib/Perl/Critic/Policy/RegularExpressions/RequireLineBoundaryMatching.pm
lib/Perl/Critic/Policy/Subroutines/ProhibitAmpersandSigils.pm
lib/Perl/Critic/Policy/Subroutines/ProhibitBuiltinHomonyms.pm
lib/Perl/Critic/Policy/Subroutines/ProhibitExcessComplexity.pm
lib/Perl/Critic/Policy/Subroutines/ProhibitExplicitReturnUndef.pm
lib/Perl/Critic/Policy/Subroutines/ProhibitSubroutinePrototypes.pm
lib/Perl/Critic/Policy/Subroutines/ProtectPrivateSubs.pm
lib/Perl/Critic/Policy/Subroutines/RequireFinalReturn.pm
lib/Perl/Critic/Policy/TestingAndDebugging/ProhibitNoStrict.pm
lib/Perl/Critic/Policy/TestingAndDebugging/ProhibitNoWarnings.pm
lib/Perl/Critic/Policy/TestingAndDebugging/ProhibitProlongedStrictureOverride.pm
lib/Perl/Critic/Policy/TestingAndDebugging/RequireTestLabels.pm
lib/Perl/Critic/Policy/TestingAndDebugging/RequireUseStrict.pm
lib/Perl/Critic/Policy/TestingAndDebugging/RequireUseWarnings.pm
lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitCommaSeparatedStatements.pm
lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitConstantPragma.pm
lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitEmptyQuotes.pm
lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitEscapedCharacters.pm
lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitInterpolationOfLiterals.pm
lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitLeadingZeros.pm
lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitMismatchedOperators.pm
lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitMixedBooleanOperators.pm
lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitNoisyQuotes.pm
lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitVersionStrings.pm
lib/Perl/Critic/Policy/ValuesAndExpressions/RequireInterpolationOfMetachars.pm
lib/Perl/Critic/Policy/ValuesAndExpressions/RequireNumberSeparators.pm
lib/Perl/Critic/Policy/ValuesAndExpressions/RequireQuotedHeredocTerminator.pm
lib/Perl/Critic/Policy/ValuesAndExpressions/RequireUpperCaseHeredocTerminator.pm
lib/Perl/Critic/Policy/Variables/ProhibitConditionalDeclarations.pm
lib/Perl/Critic/Policy/Variables/ProhibitLocalVars.pm
lib/Perl/Critic/Policy/Variables/ProhibitMatchVars.pm
lib/Perl/Critic/Policy/Variables/ProhibitPackageVars.pm
lib/Perl/Critic/Policy/Variables/ProhibitPerl4PackageNames.pm
lib/Perl/Critic/Policy/Variables/ProhibitPunctuationVars.pm
lib/Perl/Critic/Policy/Variables/ProtectPrivateVars.pm
lib/Perl/Critic/Policy/Variables/RequireInitializationForLocalVars.pm
lib/Perl/Critic/Policy/Variables/RequireLexicalLoopIterators.pm
lib/Perl/Critic/Policy/Variables/RequireNegativeIndices.pm
lib/Perl/Critic/PolicyFactory.pm
lib/Perl/Critic/PolicyListing.pm
lib/Perl/Critic/ProfilePrototype.pm
lib/Perl/Critic/TestUtils.pm
lib/Perl/Critic/Theme.pm
lib/Perl/Critic/UserProfile.pm
lib/Perl/Critic/Utils.pm
lib/Perl/Critic/Violation.pm
t/00_modules.t

diff --git a/Changes b/Changes
index 8b36c76..e517f5c 100644 (file)
--- a/Changes
+++ b/Changes
@@ -5,6 +5,11 @@
 # $Revision$
 ##############################################################################
 
+[1.05]  Released on 2007-03-19
+
+     Bug Fixes:
+     * 25557: t/20_policy_prohibittrailingwhitespace.t fails on Perl 5.8.0
+
 [1.04]  Released on 2007-03-18
 
      Bug Fixes:
diff --git a/INSTALL b/INSTALL
index cb28b84..03ed6cd 100644 (file)
--- a/INSTALL
+++ b/INSTALL
@@ -18,8 +18,8 @@ INSTALLATION
      To install Perl::Critic with C<make> give the following 
      commands to your favorite shell:
 
-         tar -zxf Perl-Critic-1.04.tar.gz
-         cd Perl-Critic-1.04
+         tar -zxf Perl-Critic-1.05.tar.gz
+         cd Perl-Critic-1.05
          perl Makefile.PL
          make
          make test
@@ -27,8 +27,8 @@ INSTALLATION
 
      Or if you prefer C<Module::Build>, try this:
 
-         tar -zxf Perl-Critic-1.04.tar.gz
-         cd Perl-Critic-1.04
+         tar -zxf Perl-Critic-1.05.tar.gz
+         cd Perl-Critic-1.05
          perl Build.pl
          ./Build
          ./Build test
index 308f787..c9c43b4 100644 (file)
--- a/META.yml
+++ b/META.yml
@@ -1,6 +1,6 @@
 ---
 name: Perl-Critic
-version: 1.04
+version: 1.05
 author:
   - Jeffrey Thalhammer <thaljef@cpan.org>
 abstract: Critique Perl source code for best-practices
@@ -29,337 +29,337 @@ recommends:
 provides:
   Perl::Critic:
     file: lib/Perl/Critic.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Config:
     file: lib/Perl/Critic/Config.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Defaults:
     file: lib/Perl/Critic/Defaults.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Document:
     file: lib/Perl/Critic/Document.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy:
     file: lib/Perl/Critic/Policy.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::BuiltinFunctions::ProhibitLvalueSubstr:
     file: lib/Perl/Critic/Policy/BuiltinFunctions/ProhibitLvalueSubstr.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::BuiltinFunctions::ProhibitReverseSortBlock:
     file: lib/Perl/Critic/Policy/BuiltinFunctions/ProhibitReverseSortBlock.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::BuiltinFunctions::ProhibitSleepViaSelect:
     file: lib/Perl/Critic/Policy/BuiltinFunctions/ProhibitSleepViaSelect.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::BuiltinFunctions::ProhibitStringyEval:
     file: lib/Perl/Critic/Policy/BuiltinFunctions/ProhibitStringyEval.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::BuiltinFunctions::ProhibitStringySplit:
     file: lib/Perl/Critic/Policy/BuiltinFunctions/ProhibitStringySplit.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::BuiltinFunctions::ProhibitUniversalCan:
     file: lib/Perl/Critic/Policy/BuiltinFunctions/ProhibitUniversalCan.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::BuiltinFunctions::ProhibitUniversalIsa:
     file: lib/Perl/Critic/Policy/BuiltinFunctions/ProhibitUniversalIsa.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::BuiltinFunctions::ProhibitVoidGrep:
     file: lib/Perl/Critic/Policy/BuiltinFunctions/ProhibitVoidGrep.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::BuiltinFunctions::ProhibitVoidMap:
     file: lib/Perl/Critic/Policy/BuiltinFunctions/ProhibitVoidMap.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::BuiltinFunctions::RequireBlockGrep:
     file: lib/Perl/Critic/Policy/BuiltinFunctions/RequireBlockGrep.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::BuiltinFunctions::RequireBlockMap:
     file: lib/Perl/Critic/Policy/BuiltinFunctions/RequireBlockMap.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::BuiltinFunctions::RequireGlobFunction:
     file: lib/Perl/Critic/Policy/BuiltinFunctions/RequireGlobFunction.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::BuiltinFunctions::RequireSimpleSortBlock:
     file: lib/Perl/Critic/Policy/BuiltinFunctions/RequireSimpleSortBlock.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::ClassHierarchies::ProhibitAutoloading:
     file: lib/Perl/Critic/Policy/ClassHierarchies/ProhibitAutoloading.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::ClassHierarchies::ProhibitExplicitISA:
     file: lib/Perl/Critic/Policy/ClassHierarchies/ProhibitExplicitISA.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::ClassHierarchies::ProhibitOneArgBless:
     file: lib/Perl/Critic/Policy/ClassHierarchies/ProhibitOneArgBless.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::CodeLayout::ProhibitHardTabs:
     file: lib/Perl/Critic/Policy/CodeLayout/ProhibitHardTabs.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::CodeLayout::ProhibitParensWithBuiltins:
     file: lib/Perl/Critic/Policy/CodeLayout/ProhibitParensWithBuiltins.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::CodeLayout::ProhibitQuotedWordLists:
     file: lib/Perl/Critic/Policy/CodeLayout/ProhibitQuotedWordLists.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::CodeLayout::ProhibitTrailingWhitespace:
     file: lib/Perl/Critic/Policy/CodeLayout/ProhibitTrailingWhitespace.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::CodeLayout::RequireConsistentNewlines:
     file: lib/Perl/Critic/Policy/CodeLayout/RequireConsistentNewlines.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::CodeLayout::RequireTidyCode:
     file: lib/Perl/Critic/Policy/CodeLayout/RequireTidyCode.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::CodeLayout::RequireTrailingCommas:
     file: lib/Perl/Critic/Policy/CodeLayout/RequireTrailingCommas.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::ControlStructures::ProhibitCStyleForLoops:
     file: lib/Perl/Critic/Policy/ControlStructures/ProhibitCStyleForLoops.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::ControlStructures::ProhibitCascadingIfElse:
     file: lib/Perl/Critic/Policy/ControlStructures/ProhibitCascadingIfElse.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::ControlStructures::ProhibitDeepNests:
     file: lib/Perl/Critic/Policy/ControlStructures/ProhibitDeepNests.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::ControlStructures::ProhibitMutatingListFunctions:
     file: lib/Perl/Critic/Policy/ControlStructures/ProhibitMutatingListFunctions.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::ControlStructures::ProhibitPostfixControls:
     file: lib/Perl/Critic/Policy/ControlStructures/ProhibitPostfixControls.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::ControlStructures::ProhibitUnlessBlocks:
     file: lib/Perl/Critic/Policy/ControlStructures/ProhibitUnlessBlocks.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::ControlStructures::ProhibitUnreachableCode:
     file: lib/Perl/Critic/Policy/ControlStructures/ProhibitUnreachableCode.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::ControlStructures::ProhibitUntilBlocks:
     file: lib/Perl/Critic/Policy/ControlStructures/ProhibitUntilBlocks.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::Documentation::RequirePodAtEnd:
     file: lib/Perl/Critic/Policy/Documentation/RequirePodAtEnd.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::Documentation::RequirePodSections:
     file: lib/Perl/Critic/Policy/Documentation/RequirePodSections.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::ErrorHandling::RequireCarping:
     file: lib/Perl/Critic/Policy/ErrorHandling/RequireCarping.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::InputOutput::ProhibitBacktickOperators:
     file: lib/Perl/Critic/Policy/InputOutput/ProhibitBacktickOperators.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::InputOutput::ProhibitBarewordFileHandles:
     file: lib/Perl/Critic/Policy/InputOutput/ProhibitBarewordFileHandles.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::InputOutput::ProhibitInteractiveTest:
     file: lib/Perl/Critic/Policy/InputOutput/ProhibitInteractiveTest.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::InputOutput::ProhibitOneArgSelect:
     file: lib/Perl/Critic/Policy/InputOutput/ProhibitOneArgSelect.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::InputOutput::ProhibitReadlineInForLoop:
     file: lib/Perl/Critic/Policy/InputOutput/ProhibitReadlineInForLoop.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::InputOutput::ProhibitTwoArgOpen:
     file: lib/Perl/Critic/Policy/InputOutput/ProhibitTwoArgOpen.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::InputOutput::RequireBracedFileHandleWithPrint:
     file: lib/Perl/Critic/Policy/InputOutput/RequireBracedFileHandleWithPrint.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::InputOutput::RequireCheckedClose:
     file: lib/Perl/Critic/Policy/InputOutput/RequireCheckedClose.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::InputOutput::RequireCheckedOpen:
     file: lib/Perl/Critic/Policy/InputOutput/RequireCheckedOpen.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::Miscellanea::ProhibitFormats:
     file: lib/Perl/Critic/Policy/Miscellanea/ProhibitFormats.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::Miscellanea::ProhibitTies:
     file: lib/Perl/Critic/Policy/Miscellanea/ProhibitTies.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::Miscellanea::RequireRcsKeywords:
     file: lib/Perl/Critic/Policy/Miscellanea/RequireRcsKeywords.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::Modules::ProhibitAutomaticExportation:
     file: lib/Perl/Critic/Policy/Modules/ProhibitAutomaticExportation.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::Modules::ProhibitEvilModules:
     file: lib/Perl/Critic/Policy/Modules/ProhibitEvilModules.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::Modules::ProhibitMultiplePackages:
     file: lib/Perl/Critic/Policy/Modules/ProhibitMultiplePackages.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::Modules::RequireBarewordIncludes:
     file: lib/Perl/Critic/Policy/Modules/RequireBarewordIncludes.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::Modules::RequireEndWithOne:
     file: lib/Perl/Critic/Policy/Modules/RequireEndWithOne.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::Modules::RequireExplicitPackage:
     file: lib/Perl/Critic/Policy/Modules/RequireExplicitPackage.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::Modules::RequireFilenameMatchesPackage:
     file: lib/Perl/Critic/Policy/Modules/RequireFilenameMatchesPackage.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::Modules::RequireVersionVar:
     file: lib/Perl/Critic/Policy/Modules/RequireVersionVar.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::NamingConventions::ProhibitAmbiguousNames:
     file: lib/Perl/Critic/Policy/NamingConventions/ProhibitAmbiguousNames.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::NamingConventions::ProhibitMixedCaseSubs:
     file: lib/Perl/Critic/Policy/NamingConventions/ProhibitMixedCaseSubs.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::NamingConventions::ProhibitMixedCaseVars:
     file: lib/Perl/Critic/Policy/NamingConventions/ProhibitMixedCaseVars.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::References::ProhibitDoubleSigils:
     file: lib/Perl/Critic/Policy/References/ProhibitDoubleSigils.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::RegularExpressions::ProhibitCaptureWithoutTest:
     file: lib/Perl/Critic/Policy/RegularExpressions/ProhibitCaptureWithoutTest.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::RegularExpressions::RequireExtendedFormatting:
     file: lib/Perl/Critic/Policy/RegularExpressions/RequireExtendedFormatting.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::RegularExpressions::RequireLineBoundaryMatching:
     file: lib/Perl/Critic/Policy/RegularExpressions/RequireLineBoundaryMatching.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::Subroutines::ProhibitAmpersandSigils:
     file: lib/Perl/Critic/Policy/Subroutines/ProhibitAmpersandSigils.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::Subroutines::ProhibitBuiltinHomonyms:
     file: lib/Perl/Critic/Policy/Subroutines/ProhibitBuiltinHomonyms.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::Subroutines::ProhibitExcessComplexity:
     file: lib/Perl/Critic/Policy/Subroutines/ProhibitExcessComplexity.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::Subroutines::ProhibitExplicitReturnUndef:
     file: lib/Perl/Critic/Policy/Subroutines/ProhibitExplicitReturnUndef.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::Subroutines::ProhibitSubroutinePrototypes:
     file: lib/Perl/Critic/Policy/Subroutines/ProhibitSubroutinePrototypes.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::Subroutines::ProtectPrivateSubs:
     file: lib/Perl/Critic/Policy/Subroutines/ProtectPrivateSubs.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::Subroutines::RequireFinalReturn:
     file: lib/Perl/Critic/Policy/Subroutines/RequireFinalReturn.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::TestingAndDebugging::ProhibitNoStrict:
     file: lib/Perl/Critic/Policy/TestingAndDebugging/ProhibitNoStrict.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::TestingAndDebugging::ProhibitNoWarnings:
     file: lib/Perl/Critic/Policy/TestingAndDebugging/ProhibitNoWarnings.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::TestingAndDebugging::ProhibitProlongedStrictureOverride:
     file: lib/Perl/Critic/Policy/TestingAndDebugging/ProhibitProlongedStrictureOverride.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::TestingAndDebugging::RequireTestLabels:
     file: lib/Perl/Critic/Policy/TestingAndDebugging/RequireTestLabels.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::TestingAndDebugging::RequireUseStrict:
     file: lib/Perl/Critic/Policy/TestingAndDebugging/RequireUseStrict.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::TestingAndDebugging::RequireUseWarnings:
     file: lib/Perl/Critic/Policy/TestingAndDebugging/RequireUseWarnings.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::ValuesAndExpressions::ProhibitCommaSeparatedStatements:
     file: lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitCommaSeparatedStatements.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::ValuesAndExpressions::ProhibitConstantPragma:
     file: lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitConstantPragma.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::ValuesAndExpressions::ProhibitEmptyQuotes:
     file: lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitEmptyQuotes.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::ValuesAndExpressions::ProhibitEscapedCharacters:
     file: lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitEscapedCharacters.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::ValuesAndExpressions::ProhibitInterpolationOfLiterals:
     file: lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitInterpolationOfLiterals.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::ValuesAndExpressions::ProhibitLeadingZeros:
     file: lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitLeadingZeros.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::ValuesAndExpressions::ProhibitMismatchedOperators:
     file: lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitMismatchedOperators.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::ValuesAndExpressions::ProhibitMixedBooleanOperators:
     file: lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitMixedBooleanOperators.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::ValuesAndExpressions::ProhibitNoisyQuotes:
     file: lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitNoisyQuotes.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::ValuesAndExpressions::ProhibitVersionStrings:
     file: lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitVersionStrings.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::ValuesAndExpressions::RequireInterpolationOfMetachars:
     file: lib/Perl/Critic/Policy/ValuesAndExpressions/RequireInterpolationOfMetachars.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::ValuesAndExpressions::RequireNumberSeparators:
     file: lib/Perl/Critic/Policy/ValuesAndExpressions/RequireNumberSeparators.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::ValuesAndExpressions::RequireQuotedHeredocTerminator:
     file: lib/Perl/Critic/Policy/ValuesAndExpressions/RequireQuotedHeredocTerminator.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::ValuesAndExpressions::RequireUpperCaseHeredocTerminator:
     file: lib/Perl/Critic/Policy/ValuesAndExpressions/RequireUpperCaseHeredocTerminator.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::Variables::ProhibitConditionalDeclarations:
     file: lib/Perl/Critic/Policy/Variables/ProhibitConditionalDeclarations.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::Variables::ProhibitLocalVars:
     file: lib/Perl/Critic/Policy/Variables/ProhibitLocalVars.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::Variables::ProhibitMatchVars:
     file: lib/Perl/Critic/Policy/Variables/ProhibitMatchVars.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::Variables::ProhibitPackageVars:
     file: lib/Perl/Critic/Policy/Variables/ProhibitPackageVars.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::Variables::ProhibitPerl4PackageNames:
     file: lib/Perl/Critic/Policy/Variables/ProhibitPerl4PackageNames.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::Variables::ProhibitPunctuationVars:
     file: lib/Perl/Critic/Policy/Variables/ProhibitPunctuationVars.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::Variables::ProtectPrivateVars:
     file: lib/Perl/Critic/Policy/Variables/ProtectPrivateVars.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::Variables::RequireInitializationForLocalVars:
     file: lib/Perl/Critic/Policy/Variables/RequireInitializationForLocalVars.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::Variables::RequireLexicalLoopIterators:
     file: lib/Perl/Critic/Policy/Variables/RequireLexicalLoopIterators.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Policy::Variables::RequireNegativeIndices:
     file: lib/Perl/Critic/Policy/Variables/RequireNegativeIndices.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::PolicyFactory:
     file: lib/Perl/Critic/PolicyFactory.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::PolicyListing:
     file: lib/Perl/Critic/PolicyListing.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::ProfilePrototype:
     file: lib/Perl/Critic/ProfilePrototype.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::TestUtils:
     file: lib/Perl/Critic/TestUtils.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Theme:
     file: lib/Perl/Critic/Theme.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::UserProfile:
     file: lib/Perl/Critic/UserProfile.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Utils:
     file: lib/Perl/Critic/Utils.pm
-    version: 1.04
+    version: 1.05
   Perl::Critic::Violation:
     file: lib/Perl/Critic/Violation.pm
-    version: 1.04
+    version: 1.05
 generated_by: Module::Build version 0.2806
 meta-spec:
   url: http://module-build.sourceforge.net/META-spec-v1.2.html
index 92ef3ca..0977c96 100755 (executable)
@@ -22,7 +22,7 @@ use Pod::Usage qw(pod2usage);
 
 #-----------------------------------------------------------------------------
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 # Begin script.  Don't run when loaded as a library
index 6494724..d44cf9f 100644 (file)
@@ -24,7 +24,7 @@ use PPI::Document::File;
 
 #-----------------------------------------------------------------------------
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 our @EXPORT_OK = qw(&critique);
 
 #-----------------------------------------------------------------------------
index 4fbc994..6546d43 100644 (file)
@@ -22,7 +22,7 @@ use Perl::Critic::Utils qw{
 
 #-----------------------------------------------------------------------------
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 # Constructor
index e9a5569..3350d8a 100644 (file)
@@ -13,7 +13,7 @@ use Carp qw(cluck);
 use English qw(-no_match_vars);
 use Perl::Critic::Utils qw{ :booleans :characters :severities :data_conversion };
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index f871dcc..a513f3e 100644 (file)
@@ -14,7 +14,7 @@ use Scalar::Util qw(weaken);
 
 #-----------------------------------------------------------------------------
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 1acd43b..3955556 100644 (file)
@@ -20,7 +20,7 @@ use Perl::Critic::Violation qw();
 use String::Format qw(stringf);
 use overload ( q{""} => 'to_string', cmp => '_compare' );
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 00398db..6e853c5 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index c484a98..d0ca36f 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 43d28d0..47ce9e2 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification :ppi };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 9a4c143..93530a4 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification :ppi };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 737b115..7bab7fb 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :characters :severities :classification :ppi };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 8abdde3..36020e1 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 2f8c641..196f90d 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 8a9bacb..f3569be 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index abe2fbf..88ca74b 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 6224471..41d2009 100644 (file)
@@ -16,7 +16,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification :ppi };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index ad26f28..0df3752 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification :ppi };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 6c66b1b..7839f9c 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 3251432..5801ab3 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 612b88c..f0a52a8 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index bfd9e5d..2f4c3db 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index a3a4dcc..a7036cd 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification :ppi };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 6b7815c..2da0a7d 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :booleans :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index d7cca4c..d5f9a31 100644 (file)
@@ -14,7 +14,7 @@ use Perl::Critic::Utils qw{
 };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 82161ab..8315ed5 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :characters :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 36d5a3e..19aae7b 100644 (file)
@@ -19,7 +19,7 @@ use Perl::Critic::Utils qw{ :characters :severities };
 
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index dfcde30..358ca8e 100644 (file)
@@ -14,7 +14,7 @@ use PPI::Token::Whitespace;
 use English qw(-no_match_vars);
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 my $LINE_END = qr/\015{1,2}\012|\012|\015/mxs;
 
index 6e58b9f..85e6b24 100644 (file)
@@ -13,7 +13,7 @@ use English qw(-no_match_vars);
 use Perl::Critic::Utils qw{ :characters :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 729cc81..5454535 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :characters :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index a9d06a8..9a8fe53 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :characters :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index d72e83a..faa88e1 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 09ef5e0..4a07caf 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index ab57e1c..f8f0601 100644 (file)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils qw{ :severities :data_conversion :classification :ppi };
 use List::MoreUtils qw( none any );
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 9bd936a..0ef2ed7 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :data_conversion :classification };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index c268053..005c88a 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 9251855..b01a70b 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :data_conversion :classification };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 my @terminals = qw( die exit croak confess );
 my %terminals = hashify( @terminals );
index 6fdb4b6..fd11474 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 53ecd53..79ae98b 100644 (file)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils qw{ :severities };
 use List::Util qw(first);
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 03cbab3..921eac8 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 3fa0549..3f9483c 100644 (file)
@@ -14,7 +14,7 @@ use Perl::Critic::Utils qw{
 };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index bd9e5df..aa3991e 100644 (file)
@@ -13,7 +13,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 368ff44..92b4260 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification :ppi };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 2e32208..beaa6ee 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index fceb410..b5eb96e 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification :ppi };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 954ea36..07a9362 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index b830f6b..01c7f61 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification :ppi };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 8d19e96..9730dbb 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification :data_conversion };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 642dae6..929adde 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index cc9ee8b..3cc9a05 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index bfb5f3a..d1386e4 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 8317645..8f13a58 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 6b6876b..d5a5a0d 100644 (file)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils qw{ :severities :data_conversion };
 use List::MoreUtils qw(none);
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index e64eb70..8a89cfb 100644 (file)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils qw{ :severities };
 use List::MoreUtils qw(any);
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 8c74bb9..ccc7dd0 100644 (file)
@@ -13,7 +13,7 @@ use List::MoreUtils qw(any);
 use Perl::Critic::Utils qw{ :severities :data_conversion };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 3faea03..cf3322e 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 98a00b8..74cc289 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 3a3c9bc..f0eeed2 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 92a0ae2..b013248 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 9811c04..95d134e 100644 (file)
@@ -13,7 +13,7 @@ use File::Spec;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 84f3a7e..8a0e07d 100644 (file)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils qw{ :severities };
 use List::MoreUtils qw(any);
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
@@ -121,8 +121,8 @@ This Policy scans your file for any package variable named
 C<$VERSION>.  I'm assuming that you are using C<strict>, so you'll
 have to declare it like one of these:
 
-  our $VERSION = 1.041;
-  $MyPackage::VERSION = 1.041;
+  our $VERSION = 1.051;
+  $MyPackage::VERSION = 1.051;
   use vars qw($VERSION);
 
 A common practice is to use the C<$Revision$> keyword to automatically
index 77e3d39..85a2d15 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :data_conversion };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 28f3421..74a4589 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index f4a5cf5..3706c7b 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index e23cb26..47d6cfe 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index e4ed956..6d0cde3 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index b88fe09..26501e4 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 029f5b2..e96817e 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 9045e5c..f3c6daa 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 7cf51d7..e61c55c 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :data_conversion :classification };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index c057ae6..3c4e5b5 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :data_conversion :classification };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index cb28514..d52012b 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index b3fbf46..6a09a73 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index edfe096..e6dafeb 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 6e0c23d..046cbca 100644 (file)
@@ -13,7 +13,7 @@ use Carp qw(confess);
 use Perl::Critic::Utils qw{ :severities :data_conversion };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index fdc5042..6a59096 100644 (file)
@@ -13,7 +13,7 @@ use List::MoreUtils qw(all);
 use Perl::Critic::Utils qw{ :severities :data_conversion };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 642eed1..e993270 100644 (file)
@@ -13,7 +13,7 @@ use List::MoreUtils qw(all);
 use Perl::Critic::Utils qw{ :severities :data_conversion };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 3859a48..a859209 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 737bb28..e3838ab 100644 (file)
@@ -15,7 +15,7 @@ use Perl::Critic::Utils qw{
 };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 my %label_arg_pos = (
    ok        => 1,
index 0aa7f5b..161ff43 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index ab5f959..c3008d7 100644 (file)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils qw{ :severities };
 use List::Util qw(first);
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 9ba2801..62f93fb 100644 (file)
@@ -14,7 +14,7 @@ use Perl::Critic::Utils qw{ :characters :severities :classification };
 
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 1e99bf5..e3fc439 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index dbad61a..e1a695e 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 30174db..b0a76e4 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 863ed4b..f168e38 100644 (file)
@@ -13,7 +13,7 @@ use List::MoreUtils qw(any);
 use Perl::Critic::Utils qw{ :severities :data_conversion };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index b97a519..ec18c2a 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 40225c4..821eb9a 100644 (file)
@@ -11,7 +11,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 9e366c8..13ef124 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :data_conversion };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 3ecba36..8a0d6f9 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 52e49a6..6dbf881 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 98c917c..9034fb5 100644 (file)
@@ -14,7 +14,7 @@ use base 'Perl::Critic::Policy';
 
 #-----------------------------------------------------------------------------
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index c76f249..049ff8e 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index d073daa..f949c67 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index cccba7b..5484c4f 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 19cac0b..ad8d22c 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification :data_conversion };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 74c3d14..3f07ad5 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :classification };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index c998a59..a1f76c8 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :data_conversion };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 0658002..d909bb6 100644 (file)
@@ -14,7 +14,7 @@ use List::MoreUtils qw(all any);
 use Carp qw( carp );
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 6f6c202..88755c4 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :characters :severities :classification };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 71954af..bef9f06 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities :data_conversion };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 56c16c6..00e204d 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 5bcc79c..2236caf 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 52390c5..a6bcf8f 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index cb721cf..82eb8d8 100644 (file)
@@ -12,7 +12,7 @@ use warnings;
 use Perl::Critic::Utils qw{ :severities };
 use base 'Perl::Critic::Policy';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index dc27b0e..9d32774 100644 (file)
@@ -21,7 +21,7 @@ use Perl::Critic::Utils qw{
     :internal_lookup
 };
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 8825c5c..cdcd595 100644 (file)
@@ -15,7 +15,7 @@ use English qw(-no_match_vars);
 use Perl::Critic::Policy qw();
 use overload ( q{""} => 'to_string');
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 3c5f0d5..4f7b730 100644 (file)
@@ -15,7 +15,7 @@ use English qw(-no_match_vars);
 use Perl::Critic::Policy qw();
 use overload ( q{""} => 'to_string' );
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 01deb1f..254ecad 100644 (file)
@@ -21,7 +21,7 @@ use Perl::Critic;
 use Perl::Critic::Utils qw{ :data_conversion };
 use Perl::Critic::PolicyFactory (-test => 1);
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 our @EXPORT_OK = qw(
     pcritique critique fcritique
     subtests_in_tree
index a1d9bea..dae5513 100644 (file)
@@ -16,7 +16,7 @@ use Perl::Critic::Utils qw{ :characters :data_conversion };
 
 #-----------------------------------------------------------------------------
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index d3c0e61..4611e4a 100644 (file)
@@ -16,7 +16,7 @@ use File::Spec qw();
 use Perl::Critic::Defaults qw();
 use Perl::Critic::Utils qw{ :characters &policy_long_name &policy_short_name };
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 
index 01ab450..ee1f360 100644 (file)
@@ -17,7 +17,7 @@ use B::Keywords qw();
 
 use base 'Exporter';
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #-----------------------------------------------------------------------------
 # Exportable symbols here.
index 7ce2d66..0a379af 100644 (file)
@@ -18,7 +18,7 @@ use Perl::Critic::Utils qw{ :characters :internal_lookup };
 use String::Format qw(stringf);
 use overload ( q{""} => 'to_string', cmp => '_compare' );
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 #Class variables...
 our $FORMAT = "%m at line %l, column %c. %e.\n"; #Default stringy format
index bdd81c7..783cfde 100644 (file)
@@ -14,7 +14,7 @@ use Test::More tests => 1471;  # Add 14 for each new policy created
 use Perl::Critic::TestUtils qw(bundled_policy_names);
 use English qw(-no_match_vars);
 
-our $VERSION = 1.04;
+our $VERSION = 1.05;
 
 # pre-compute for version comparisons
 my $version_string = __PACKAGE__->VERSION;