Login
We need to use Test::POD version 1.41 or newer, because older
authorJeffrey Ryan Thalhammer <jeff@imaginative-software.com>
Thu, 19 May 2011 03:15:29 +0000 (03:15 +0000)
committerJeffrey Ryan Thalhammer <jeff@imaginative-software.com>
Thu, 19 May 2011 03:15:29 +0000 (03:15 +0000)
versions don't permit L<text|scheme:...> links.  This actually
was verbotten in older perls.  But since about 5.11, it is
supported.

I suppose we could write a Policy that would forbid the
L<text|scheme:...> style of links if the target perl is not
5.11 or higher.  But this feels like re-inventing the wheel,
since Test::POD is already out there.

xt/author/98_pod_syntax.t

index 0ae9a22..59d6bef 100644 (file)
@@ -13,7 +13,7 @@ use warnings;
 
 use Perl::Critic::TestUtils qw{ starting_points_including_examples };
 
-use Test::More;
+use Test::More;# 1.41;  # Need 1.41 or newer for correct support of L<text|scheme:...> links.
 
 #-----------------------------------------------------------------------------