Login
Increased $VERSION to 0.14.
authorJeffrey Ryan Thalhammer <jeff@imaginative-software.com>
Thu, 5 Jan 2006 04:29:14 +0000 (04:29 +0000)
committerJeffrey Ryan Thalhammer <jeff@imaginative-software.com>
Thu, 5 Jan 2006 04:29:14 +0000 (04:29 +0000)
66 files changed:
Changes
INSTALL
META.yml
bin/perlcritic
lib/Perl/Critic.pm
lib/Perl/Critic/Config.pm
lib/Perl/Critic/Policy.pm
lib/Perl/Critic/Policy/BuiltinFunctions/ProhibitLvalueSubstr.pm
lib/Perl/Critic/Policy/BuiltinFunctions/ProhibitSleepViaSelect.pm
lib/Perl/Critic/Policy/BuiltinFunctions/ProhibitStringyEval.pm
lib/Perl/Critic/Policy/BuiltinFunctions/RequireBlockGrep.pm
lib/Perl/Critic/Policy/BuiltinFunctions/RequireBlockMap.pm
lib/Perl/Critic/Policy/BuiltinFunctions/RequireGlobFunction.pm
lib/Perl/Critic/Policy/ClassHierarchies/ProhibitOneArgBless.pm
lib/Perl/Critic/Policy/CodeLayout/ProhibitHardTabs.pm
lib/Perl/Critic/Policy/CodeLayout/ProhibitParensWithBuiltins.pm
lib/Perl/Critic/Policy/CodeLayout/ProhibitQuotedWordLists.pm
lib/Perl/Critic/Policy/CodeLayout/RequireTidyCode.pm
lib/Perl/Critic/Policy/CodeLayout/RequireTrailingCommas.pm
lib/Perl/Critic/Policy/ControlStructures/ProhibitCStyleForLoops.pm
lib/Perl/Critic/Policy/ControlStructures/ProhibitCascadingIfElse.pm
lib/Perl/Critic/Policy/ControlStructures/ProhibitPostfixControls.pm
lib/Perl/Critic/Policy/ControlStructures/ProhibitUnlessBlocks.pm
lib/Perl/Critic/Policy/ControlStructures/ProhibitUntilBlocks.pm
lib/Perl/Critic/Policy/InputOutput/ProhibitBacktickOperators.pm
lib/Perl/Critic/Policy/InputOutput/ProhibitBarewordFileHandles.pm
lib/Perl/Critic/Policy/InputOutput/ProhibitOneArgSelect.pm
lib/Perl/Critic/Policy/InputOutput/ProhibitTwoArgOpen.pm
lib/Perl/Critic/Policy/Miscellanea/RequireRcsKeywords.pm
lib/Perl/Critic/Policy/Modules/ProhibitEvilModules.pm
lib/Perl/Critic/Policy/Modules/ProhibitMultiplePackages.pm
lib/Perl/Critic/Policy/Modules/RequireBarewordIncludes.pm
lib/Perl/Critic/Policy/Modules/RequireEndWithOne.pm
lib/Perl/Critic/Policy/Modules/RequireExplicitPackage.pm
lib/Perl/Critic/Policy/Modules/RequireVersionVar.pm
lib/Perl/Critic/Policy/NamingConventions/ProhibitAmbiguousNames.pm
lib/Perl/Critic/Policy/NamingConventions/ProhibitMixedCaseSubs.pm
lib/Perl/Critic/Policy/NamingConventions/ProhibitMixedCaseVars.pm
lib/Perl/Critic/Policy/References/ProhibitDoubleSigils.pm
lib/Perl/Critic/Policy/RegularExpressions/RequireExtendedFormatting.pm
lib/Perl/Critic/Policy/RegularExpressions/RequireLineBoundaryMatching.pm
lib/Perl/Critic/Policy/Subroutines/ProhibitAmpersandSigils.pm
lib/Perl/Critic/Policy/Subroutines/ProhibitBuiltinHomonyms.pm
lib/Perl/Critic/Policy/Subroutines/ProhibitExcessComplexity.pm
lib/Perl/Critic/Policy/Subroutines/ProhibitExplicitReturnUndef.pm
lib/Perl/Critic/Policy/Subroutines/ProhibitSubroutinePrototypes.pm
lib/Perl/Critic/Policy/Subroutines/RequireFinalReturn.pm
lib/Perl/Critic/Policy/TestingAndDebugging/ProhibitNoStrict.pm
lib/Perl/Critic/Policy/TestingAndDebugging/ProhibitNoWarnings.pm
lib/Perl/Critic/Policy/TestingAndDebugging/RequireUseStrict.pm
lib/Perl/Critic/Policy/TestingAndDebugging/RequireUseWarnings.pm
lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitConstantPragma.pm
lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitEmptyQuotes.pm
lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitInterpolationOfLiterals.pm
lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitLeadingZeros.pm
lib/Perl/Critic/Policy/ValuesAndExpressions/ProhibitNoisyQuotes.pm
lib/Perl/Critic/Policy/ValuesAndExpressions/RequireInterpolationOfMetachars.pm
lib/Perl/Critic/Policy/ValuesAndExpressions/RequireNumberSeparators.pm
lib/Perl/Critic/Policy/ValuesAndExpressions/RequireQuotedHeredocTerminator.pm
lib/Perl/Critic/Policy/ValuesAndExpressions/RequireUpperCaseHeredocTerminator.pm
lib/Perl/Critic/Policy/Variables/ProhibitLocalVars.pm
lib/Perl/Critic/Policy/Variables/ProhibitPackageVars.pm
lib/Perl/Critic/Policy/Variables/ProhibitPunctuationVars.pm
lib/Perl/Critic/Utils.pm
lib/Perl/Critic/Violation.pm
t/00_modules.t

diff --git a/Changes b/Changes
index aaf65cb..dca5388 100644 (file)
--- a/Changes
+++ b/Changes
@@ -5,9 +5,16 @@
 # $Revision$
 ########################################################################
 
-[0.13_05] Released on 060102
+[0.14] Released on 060104
 
-     Final candidate for version 0.14
+     Official release.  No change from 0.13_05.
+
+[0.13_05] Not released
+
+     More documentation edits.
+
+     Bug Fixes:
+     * 16906:  tr/// created false-postives with RegularExpression polices.
 
 [0.13_04] Released on 051231
 
diff --git a/INSTALL b/INSTALL
index 8fadbc9..f93ec1b 100644 (file)
--- a/INSTALL
+++ b/INSTALL
@@ -18,8 +18,8 @@ INSTALLATION
      To install Perl::Critic with C<make> give the following 
      commands to your favorite shell:
 
-         tar -zxf Perl-Critic-0.13_05.tar.gz
-         cd Perl-Critic-0.13_05
+         tar -zxf Perl-Critic-0.14.tar.gz
+         cd Perl-Critic-0.14
          perl Makefile.PL
          make
          make test
@@ -27,8 +27,8 @@ INSTALLATION
 
      Or if you prefer C<Module::Build>, try this:
 
-         tar -zxf Perl-Critic-0.13_05.tar.gz
-         cd Perl-Critic-0.13_05
+         tar -zxf Perl-Critic-0.14.tar.gz
+         cd Perl-Critic-0.14
          perl Build.pl
          ./Build
          ./Build test
index 6964177..80b781d 100644 (file)
--- a/META.yml
+++ b/META.yml
@@ -1,7 +1,7 @@
 # http://module-build.sourceforge.net/META-spec.html
 #XXXXXXX This is a prototype!!!  It will change in the future!!! XXXXX#
 name:         Perl-Critic
-version:      0.13_05
+version:      0.14
 version_from: lib/Perl/Critic.pm
 installdirs:  site
 requires:
index 55136c6..cd67a1e 100755 (executable)
@@ -18,7 +18,7 @@ use English qw(-no_match_vars);
 use Perl::Critic::Utils;
 use Perl::Critic;
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 my %options    = ();
index 8128a2a..300ea52 100755 (executable)
@@ -16,7 +16,7 @@ use Perl::Critic::Utils;
 use Carp;
 use PPI;
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #----------------------------------------------------------------------------
index ba00db2..597e157 100755 (executable)
@@ -16,7 +16,7 @@ use List::MoreUtils qw(any none);
 use Perl::Critic::Utils;
 use Carp qw(carp croak);
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 # Globals.  Ick!
index 1f52e0e..1f89d7d 100755 (executable)
@@ -11,7 +11,7 @@ use strict;
 use warnings;
 use Perl::Critic::Utils;
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #----------------------------------------------------------------------------
index 0775ae4..3b16cdd 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION; ## no critic;
 
 #----------------------------------------------------------------------------
index baf8af8..ed35786 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION; ## no critic;
 
 #------------------------------------------------------------------------
index c91f847..c6d12a6 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #----------------------------------------------------------------------------
index 4845aa2..ecc2b37 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #----------------------------------------------------------------------------
index a5f7199..2e95ac1 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #----------------------------------------------------------------------------
index f4165d9..707de4f 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #----------------------------------------------------------------------------
index 4962c4d..0977848 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION; ## no critic
 
 #--------------------------------------------------------------------------
index 4102d50..fd32f24 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 my $desc = q{Hard tabs used};
index 1942084..c03ff2b 100755 (executable)
@@ -14,7 +14,7 @@ use Perl::Critic::Violation;
 use List::MoreUtils qw(any);
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #----------------------------------------------------------------------------
index a03be72..b5401f3 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #---------------------------------------------------------------------------
index af06e2e..ff2cc3b 100755 (executable)
@@ -14,7 +14,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #----------------------------------------------------------------------------
index bedbef2..7a4b5d7 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #----------------------------------------------------------------------------
index a941520..89da18d 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Violation;
 use Perl::Critic::Utils;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #----------------------------------------------------------------------------
index 401875f..699d58b 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Violation;
 use Perl::Critic::Utils;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #----------------------------------------------------------------------------
index 1c33beb..15334bb 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Violation;
 use Perl::Critic::Utils;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #----------------------------------------------------------------------------
index 5454b57..456a258 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Violation;
 use Perl::Critic::Utils;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #----------------------------------------------------------------------------
index a7c8430..97f48b3 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Violation;
 use Perl::Critic::Utils;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #----------------------------------------------------------------------------
index e36d3eb..e0cc798 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #----------------------------------------------------------------------------
index 8894231..b2133e3 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION; ## no critic
 
 #--------------------------------------------------------------------------
index c10d087..d0e59c9 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION; ## no critic
 
 #--------------------------------------------------------------------------
index 1f9a07f..e429dcc 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION; ## no critic
 
 #--------------------------------------------------------------------------
index 7c0e973..76ea673 100755 (executable)
@@ -14,7 +14,7 @@ use Perl::Critic::Violation;
 use List::MoreUtils qw(none);
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #---------------------------------------------------------------------------
index 8efd41e..a508a76 100755 (executable)
@@ -6,7 +6,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 my $expl = q{Find an alternative module};
index 2fb491d..3d9db7c 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #----------------------------------------------------------------------------
index cc7fd2d..737319d 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #----------------------------------------------------------------------------
index 02d683d..b96aef3 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #----------------------------------------------------------------------------
index 5e1447e..7594d31 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #----------------------------------------------------------------------------
index b27451a..9421b0f 100755 (executable)
@@ -14,7 +14,7 @@ use Perl::Critic::Violation;
 use List::MoreUtils qw(any);
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #---------------------------------------------------------------------------
index 1b2c65a..38c1358 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Violation;
 use Perl::Critic::Utils;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #---------------------------------------------------------------------------
index 6b57e99..a74e228 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #---------------------------------------------------------------------------
index f4709d9..ea18dc0 100755 (executable)
@@ -14,7 +14,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #---------------------------------------------------------------------------
index 92e03a6..ec413d1 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #----------------------------------------------------------------------------
index 7349518..7fd307e 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Violation;
 use Perl::Critic::Utils;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #----------------------------------------------------------------------------
index f2cc73e..e54368f 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Violation;
 use Perl::Critic::Utils;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #----------------------------------------------------------------------------
index 3851a28..9cddd3d 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #---------------------------------------------------------------------------
index 13bf3dd..58ab081 100755 (executable)
@@ -14,7 +14,7 @@ use Perl::Critic::Violation;
 use List::MoreUtils qw(any);
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #---------------------------------------------------------------------------
index 53e7aa7..e428d81 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #---------------------------------------------------------------------------
index 76d5be5..af74c71 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #---------------------------------------------------------------------------
index f2bdea6..d018dc3 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #---------------------------------------------------------------------------
index 41edfc5..d4207c1 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #---------------------------------------------------------------------------
index 473a669..542d28d 100755 (executable)
@@ -14,7 +14,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #---------------------------------------------------------------------------
index f89f9a8..03a0f53 100755 (executable)
@@ -14,7 +14,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #---------------------------------------------------------------------------
index 4e4216e..827923a 100755 (executable)
@@ -14,7 +14,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #---------------------------------------------------------------------------
index fe8243f..c692c67 100755 (executable)
@@ -14,7 +14,7 @@ use List::Util qw(first);
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #---------------------------------------------------------------------------
index 1ad3078..798ba30 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #---------------------------------------------------------------------------
index 3ac9093..9752156 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #---------------------------------------------------------------------------
index a6707a0..4891a0b 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #---------------------------------------------------------------------------
index 6da9aa3..ee7e83a 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #---------------------------------------------------------------------------
index b5e24e3..4124e7a 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #---------------------------------------------------------------------------
index 1714f6a..8fbfb9d 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #---------------------------------------------------------------------------
index 4a648dd..df83f9c 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #---------------------------------------------------------------------------
index 6e8c676..5bfec10 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #---------------------------------------------------------------------------
index 0ea7ff5..6b2dcc8 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #---------------------------------------------------------------------------
index 38989cd..ab54c1a 100755 (executable)
@@ -14,7 +14,7 @@ use Perl::Critic::Violation;
 use List::MoreUtils qw(none);
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #---------------------------------------------------------------------------
index def3142..1e4683a 100755 (executable)
@@ -14,7 +14,7 @@ use Perl::Critic::Violation;
 use List::MoreUtils qw(all);
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #---------------------------------------------------------------------------
index 2941747..9ad9bb3 100755 (executable)
@@ -13,7 +13,7 @@ use Perl::Critic::Utils;
 use Perl::Critic::Violation;
 use base 'Perl::Critic::Policy';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #---------------------------------------------------------------------------
index 642fa59..cd0b5ee 100755 (executable)
@@ -11,7 +11,7 @@ use strict;
 use warnings;
 use base 'Exporter';
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #---------------------------------------------------------------------------
index 295929c..20c7763 100755 (executable)
@@ -18,7 +18,7 @@ use English qw(-no_match_vars);
 use overload q{""} => 'to_string';
 use UNIVERSAL qw(isa);
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;    ## no critic
 
 #Class variables...
index 1ba7c1b..eb75cea 100755 (executable)
@@ -11,7 +11,7 @@ use PPI::Document;
 use Test::More tests => 539;
 use English qw(-no_match_vars);
 
-our $VERSION = '0.13_05';
+our $VERSION = '0.14';
 $VERSION = eval $VERSION;  ## pc:skip
 
 my $obj = undef;