Login
Bump required version of PPIx::Regexp to 0.019, since that is the
authorTom Wyant <harryfmudd@comcast.net>
Wed, 13 Apr 2011 00:31:48 +0000 (00:31 +0000)
committerTom Wyant <harryfmudd@comcast.net>
Wed, 13 Apr 2011 00:31:48 +0000 (00:31 +0000)
version that understands the most about things like ${foo}. Version
0.020 is out, but that was a tweak in the minimum Perl version
functionality, which Perl::Critic does not use.

Changes
inc/Perl/Critic/BuildUtilities.pm

diff --git a/Changes b/Changes
index f2101cb..12801b9 100644 (file)
--- a/Changes
+++ b/Changes
@@ -1,6 +1,8 @@
 Whenever the next release is
 
     Policy Changes:
+    * RegularExpressions::ProhibitUnusedCapture should more reliably
+      find things like s/(a)/${1}2/.  RT #67273.
     * Documentation::RequirePodSections no longer blows up on code
       having POD but no =head1. This problem was introduced with RT
       #59268. RT #67231
index 30661ea..d6fae44 100644 (file)
@@ -58,7 +58,7 @@ sub required_module_versions {
         'PPI::Node'                     => '1.215',
         'PPI::Token::Quote::Single'     => '1.215',
         'PPI::Token::Whitespace'        => '1.215',
-        'PPIx::Regexp'                  => 0.010,
+        'PPIx::Regexp'                  => '0.019', # RT 67273
         'PPIx::Utilities::Node'         => '1.001',
         'PPIx::Utilities::Statement'    => '1.001',
         'Perl::Tidy'                    => 0,