Login
Add a separate configuration item, 'allow_perl_version', to
authorTom Wyant <harryfmudd@comcast.net>
Fri, 9 Dec 2011 00:14:08 +0000 (00:14 +0000)
committerTom Wyant <harryfmudd@comcast.net>
Fri, 9 Dec 2011 00:14:08 +0000 (00:14 +0000)
commit231a771014ad2a51e13d5b5f4696188d52cb4657
tree4e0c67cf80ab788d9a2a66e273d2b08af47b7a24
parenteec4ffdfd700c0753f97ac8fa267d2dcc94269bb
Add a separate configuration item, 'allow_perl_version', to
Modules::RequireExplicitPackage to allow things like 'use 5.010;', since
this is the one use of 'use' not covered in commits 4098 and 4099 (RT
#72660).
Changes
lib/Perl/Critic/Policy/Modules/RequireExplicitPackage.pm
t/Modules/RequireExplicitPackage.run