Login
#68498 for Perl-Critic: Missing 'use version' prevents Red Hat install
authorTom Wyant <harryfmudd@comcast.net>
Fri, 27 May 2011 18:41:02 +0000 (18:41 +0000)
committerTom Wyant <harryfmudd@comcast.net>
Fri, 27 May 2011 18:41:02 +0000 (18:41 +0000)
commit16942e876c7b0729110cbb1cb8b2f1a885fd2a5c
tree3bfe7132a9f61c27be54f665035105397f307aa9
parent9b3ec307a27e11bcedff6af6e21b250218a93bd5
#68498 for Perl-Critic: Missing 'use version' prevents Red Hat install

Added the 'use version'. Obviously any module that calls version->new()
needs 'version' loaded. It was just the luck (or unluck) of load order
that made this work in so many places.
Changes
lib/Perl/Critic/Policy/BuiltinFunctions/ProhibitLvalueSubstr.pm