Login
Documentation edits.
[gknop/Perl-Critic.git] / Makefile.PL
CommitLineData
02b7b45d
JRT
1#######################################################################
2# $URL$
3# $Date$
4# $Author$
5# $Revision$
6########################################################################
7
59b05e08
JRT
8use strict;
9use warnings;
59b05e08
JRT
10use ExtUtils::MakeMaker;
11
a4141f24
JRT
12warn <<'END_WARNING';
13###################################################
14# NOTICE! NOTICE! NOTICE! NOTICE! NOTICE! NOTICE! #
15#-------------------------------------------------#
16# In this version of Perl::Critic, some of #
17# the Policy modules have been renamed to better #
18# better reflect the intent of the Policy. If #
19# you have an older version of Perl::Critic #
20# already installed, it will cause many of the #
21# tests to fail and the new version will not work #
22# properly. #
23# #
24# I strongly advise you to remove the current #
25# version of Perl::Critic before proceeding with #
26# this installation. In most cases, this can be #
27# done by deleting everything below the #
28# Perl/Critic/Policy directory in your site_perl #
29# location. #
30# #
31# Also, if you have created a .perlcriticrc file, #
32# you will need to update it to match the new #
33# Policy module names. #
34# #
35# Sorry for the inconvenience. #
36# #
37# -Jeff <thaljef@cpan.org> #
38###################################################
39END_WARNING
40
59b05e08
JRT
41WriteMakefile( NAME => 'Perl::Critic',
42 AUTHOR => 'Jeffrey Thalhammer <thaljef@cpan.org>',
43 ABSTRACT_FROM => 'lib/Perl/Critic.pm',
44 VERSION_FROM => 'lib/Perl/Critic.pm',
45 EXE_FILES => ['bin/perlcritic'],
46 PL_FILES => {},
47 PREREQ_PM => {'PPI' => 1.103,
48 'Config::Tiny' => 2,
49 'File::Spec' => 0,
50 'List::MoreUtils' => 0,
51 'List::Util' => 0,
52 'Pod::Usage' => 0,
53 'Pod::PlainText' => 0,
54 'Test::More' => 0,
55 'IO::String' => 0,
56 'String::Format' => 1.13,
dff08b70 57 'Module::Pluggable' => 0,
59b05e08
JRT
58 },
59
60);